Installing OpenShot on Ubuntu 10.10 mucked with VLC and other codecs, etc.

I installed OpenShot yesterday and published my first Youtube vid edited with it: And i've embedded it here just coz it involves cats, and we all love cats... right?

Later on I observed that VLC was no longer installed on my machine.
I also observed I had some videos that wouldn't play anymore (in totem) due to missing Codecs.

I was prompted to check my apt/history.log file after someone on Facebook doubted the correlation... I suppose I should stop openly blaming things without checking... so glad I looked:

Here's an extract:

Start-Date: 2011-12-27 19:36:05
Commandline: apt-get install openshot
Install: melt:amd64 (0.5.6+git20100727-1, automatic), libavformat-extra-52:amd64 (0.6-2ubuntu3.2, automatic), openshot:amd64 (1.2.2-1), libatlas3gf-base:amd64 (3.8.3-22ubuntu2, automatic), libmlt++3:amd64 (0.5.6+git20100727-1, automatic), libsox-fmt-base:amd64 (14.3.1-1build1, automatic), libquicktime1:amd64 (1.1.5-1, automatic), python-mlt2:amd64 (0.5.6+git20100727-1, automatic), libsox-fmt-alsa:amd64 (14.3.1-1build1, automatic), libavutil-extra-50:amd64 (0.6-2ubuntu3.2, automatic), libcvaux2.1:amd64 (2.1.0-2, automatic), libavdevice52:amd64 (0.6-2ubuntu6.2, automatic), libpostproc-extra-51:amd64 (0.6-2ubuntu3.2, automatic), libmp3lame0:amd64 (3.98.4-0ubuntu1, automatic), openshot-doc:amd64 (1.2.2-1, automatic), libhighgui2.1:amd64 (2.1.0-2, automatic), libswscale-extra-0:amd64 (0.6-2ubuntu3.2, automatic), libgavl1:amd64 (1.1.2-3, automatic), frei0r-plugins:amd64 (1.1.22git20091109-1.1, automatic), libqt4-svg:amd64 (4.7.0-0ubuntu4.4, automatic), libcv2.1:amd64 (2.1.0-2, automatic), libxvidcore4:amd64 (1.2.2+debian-1ubuntu2, automatic), libgfortran3:amd64 (4.5.1-7ubuntu2, automatic), librtmp0:amd64 (2.3-2, automatic), libsox1b:amd64 (14.3.1-1build1, automatic), libmlt-data:amd64 (0.5.6+git20100727-1, automatic), libopenjpeg2:amd64 (1.3+dfsg-4, automatic), libmlt2:amd64 (0.5.6+git20100727-1, automatic), libavcodec-extra-52:amd64 (0.6-2ubuntu3.2, automatic)

Remove: libswscale0:amd64 (0.6.2-1ubuntu1~ppa1~lucid1), libavutil50:amd64 (0.6.2-1ubuntu1~ppa1~lucid1), libavcodec52:amd64 (0.6.2-1ubuntu1~ppa1~lucid1), gstreamer0.10-ffmpeg:amd64 (0.10.11-1), vlc-nox:amd64 (1.1.4-1ubuntu1.7), vlc-plugin-notify:amd64 (1.1.4-1ubuntu1.7), libpostproc51:amd64 (0.6.2-1ubuntu1~ppa1~lucid1), libavformat52:amd64 (0.6.2-1ubuntu1~ppa1~lucid1), vlc:amd64 (1.1.4-1ubuntu1.7), vlc-plugin-pulse:amd64 (1.1.4-1ubuntu1.7)
End-Date: 2011-12-27 19:38:00

plenty of vlc packages removed as a result of installing OpenShot... and a swag of codecs...
reinstalled vlc and let totem go codec hunting, at least I have a list of what's missing now should I need it... I should've paid more attention to what it was up to I think!